Control parental con opendns en una red lan


#1

Hola a todos ¿ como están ? Espero que bien.

Sigo sin solucionar un tema que pregunté hace mucho, tengo opendns pero lo quiero implementar en toda mi red lan.

Mi router es mikrotik con licencia nivel 4 y mi ISP se llama Neu Net, al parecer me obliga a usar sus DNS.

Quisiera saber como puedo hacer para poder tener opendns en toda mi red lan ?. muchos me van a decir cambia los dns del router y listo pero lo hago y no funciona.

El tema de hacer pools de ip no lo quiero hacer porque mi idea es si o si bloquear todo el xxx, paginas de virus y demás.

Segun investigué tambien debo usar opendns + dnsomatic, pero el problema es que no me deja cargar mis datos de opendns en la pagina de dnsomatic.

¿ Alguno me podrá iluminar ?.

Desde ya muchas gracias.

Espero novedades.


#2

Es muy sencillo en tu DHCP server, tenes que ofrecer los DNS de OpenDNS y usa este script en el scheduler para que te mantenga la IP de la WAN actualizada y Open pueda filtrar el contenido. No tiene mucho mas mistero que eso

#--------------- Change Values in this section to match your setup ------------------

# User account info of OpenDNS

# Update-only password (obtained from OpenDNS Support). With two-factor authentication enabled, the use of an update only password is required. 

:local odnsuser "[email protected]"
:local odnspass "update-only-password"

# Set the hostname or label of network to be updated. This is the name of your OpenDNS network on the Dashboard. 
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host name.
# Only one host is supported
# Use "all.dnsomatic.com" for the matichost to update all items in dnsomatic with this IP.

# Note, you must have admin or edit (Read/Write/Grant in the OpenDNS Dashboard) to update IP addresses. 

:local odnshost "networkname"

# Change to the name of interface that gets the changing IP address

# May not be needed for your model number - commenting out this line may still work for single interface devices or if this is not supplied in the DNS-O-Matic script currently being used

:local inetinterface "ether1"

#------------------------------------------------------------------------------------

# No more changes needed, one optional change

:global previousIP;

:log info "Fetching current IP"

# Get the current public IP using DNS-O-Matic service.
/tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=mypublicip.txt

# Read the current public IP into the currentIP variable.
:local currentIP [/file get mypublicip.txt contents]

:log info "Fetched current IP as $currentIP"

# --------- Optional check to only run if the IP has changed (one line: :if)

# to enable, set line below to: ":if ($currentIP != $currentIP) do={"

:if ($currentIP != 1) do={
:log info "OpenDNS: Update needed"
:set previousIP $currentIP

# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.

# Some older editions of the MicroTik/WinBox OS require the following line instead (http) whereas newer versions require https.

# :local url "http://updates.opendns.com/nic/update\3Fhostname=$odnshost"
:local url "https://updates.opendns.com/nic/update\3Fhostname=$odnshost"
:log info "OpenDNS: Sending update for $odnshost"

/tool fetch url=($url) user=$odnsuser password=$odnspass mode=http dst-path=("/net_odns.txt")

:delay 2;

:local odnsReply [/file get net_odns.txt contents];

:log info "OpenDNS update complete."

:log info "OpenDNS reply was $odnsReply";

} else={

:log info "OpenDNS: Previous IP $previousIP and current IP equal, no update need"
}`

#3

A ver me das una mano ? te paso una captura de pantalla de mi Mikrotik:

Decime en que apartado pego eso que me diste ?.


#4

y aca que va ?

:local odnsuser "[email protected]"
:local odnspass “update-only-password”


#5

La más facil es borrar el dhcp server que tenes, despues click en DHCP setup, y vas configurando, cuando te pida los DNS server, escribis los de OpenDNS y terminas de configurarlo.
Y en las variables, entre las comillas reemplazas tus datos de login a OpenDNS, tu mail y tu password respectivamente


#6

me parece muy complejo lo que me decis, tengo que ir haciendo todo a mano. ( y si ya me fije, son muchos parametros que tengo que hacer ).

Mejor voy a contratar a alguien que me ayude.

Gracias igual.


#7

Nahh, es sencillo, la primer pantalla te pide la interfaz: seleccionas la del bridge y despues te rellena los datos automaticamente. Lo unico que tendrias que cambiar serian los DNSs por los de OpenDNS. Igual siempre hace un backup antes. Si no te animas o no tenes mucha idea por ahi si te conviene pedir soporte. Abrazo


#8

voy a probar porque recien hice back up de datos. Pero probaré despues porque me puedo mandar alguna cagada y dejaría a todos sin internet…


#9

Utlima consulta: @logico en que momento pego ese script que me diste arriba ?.

Gracias.


#10

El script va en system -> scheduler
Click en el boton new y lo pegas en el cuadro de texto “On Event”. En interval dale 5 minutos (00:05:00) y start time ponelo en startup para que arranque cuando inicia el router


#11

@logico sabes que hice todo lo que vos me dijiste pero en la seccion del DHCP yo le puse los DNS de opendns y los demás parametros ni idea que debia poner, luego puse el script con mi correo y contraseña ( las que uso en opendns ) el tema es que de ahi se me tumbo mi red y me quedé por muchas hs sin internet. No pude entrar nunca más al mikrotik ni por webfig ni SSH ni por más que le haga hard reset fisicos con agujas ( les hice mucho ) y nada ni aplicaba efectos de restauracion de fabrica.

En resumidas cuentas:

me quedé por muchas hs sin internet, y tuve que cambiar de router.

¿ que curioso no ?. Ese mikrotik siempre me trajo muchos problemas a la más minima e insignificante configuracion…

el tema es que me suena mucho es que … :

por más que yo le haga 999999 cambios a mi mikrotik y 9999 hard reset fisicos, no se daña ni se arruina ni se pierde " teoricamente " mi licencia nivel 4 del mismo mikrotik. Al menos a que se prenda fuego o le agarre agua ( segun tengo entendido ). Me imagino que debe ser más o menos lo mismo en los demás Routers o firewalls profesionales, no se pierde ni se arruina facilmente las licencias.

Bueno espero alguna conclusion o respuesta tuya.

Gracias.


#12

Mi recomendación seria: no tengas un aparato que no podes controlar. Segundo siempre tenes que jugar seguro y hacer todo con backups y por sobre todas las cosas entender lo que estas haciendo.
Con respecto a licencia no te preocupes porque esta “hardwired” al hardware asi que no te preocupes, podes reiniciarlo mil veces con la aguja.
Si alguna vez perdes conexion con el router usa el winbox que se conecta al Mikrotik por MAC, y restaura a fabrica o el backup que hiciste.

La conclusión es que lo que queres hacer es una de las configuraciones mas sensillas que podes hacer en este tipo de routers. Bien podes aprender networking y administración de Mikrotik en particular o conseguirte un router mas amigable (Tp-Link, Linksys, etc) que te permita hacer estas cosas sin tantas complicaciones.

Saludos


#13

Amigo @lógico bueno me cuesta etiquetar te porque estoy en el celular.

Obvio me compre el mikrotik para practicar y aprender pero me dio muchos dolores de cabeza.

No se si lo dije pero volví a un tp link común y me anda de diez, lo compre nuevo.

Que te iba a decir… Antes de hacer eso que me dijiste arriba ya tenia back up pero el problema es que ahora no me deja entrar como dije anteriormente ni por SSH ni webfig ni winbox ni por ip ni por Mac como dijiste recién. Que raro no ?. Bueno creo que esta consulta del porqué no responde mi mikrotik quizás merece un post a parte.

Ahora bien, respetando el hilo de este post del " como solucionar el tema de opendns aplicado a mi router en mi red lan ". ¿ Debo hacer lo mismo en la parte de DHCP de mi router tp link y obvio sin tirar ese script ?. Porque creo que tp link no admite poner script (( hasta donde se, no se puede )).

Muchas gracias por tu disposición.


#14

Intenta por ethernet a puerto 1. A veces resetearlos es un poco mas complejo en los Mikrotiks, tenese que desconectar todos los cables y el de power, mantenes el boton de reset presionado y conectas el power. Aca hay un video https://www.youtube.com/watch?v=8Lpeq8HR4_8

Exacto, haces lo mismo en DHCP -> DHCP settings y llenas los campos DNS Server y Secondary DNS Server con las IPs de OpenDNS. Como no se ejecuta el script de actualización de IP, tenes que bajarte el cliente IP Updater en alguna computadora que este siempre encendida y lo configuras con tus datos de OpenDNS